Jump to content

  1. 0
  2. 0
  3. 0/5

Rate this Topic

- - - - -

Sd Card Not Accessible....not Mounted?

  • Please log in to reply

OP fubar11

fubar11

Average Android

  • 9 posts

Posted 06 November 2011 - 11:33 AM #1

I'm having some issues with the sd card on my touchpad with the newest version of CM7. It seems that the sd card unmounts itself a while after I've rebooted the device. For example, I can't delete files on my sd card with Astro after that happens or download files from dropbox. Sometimes it works for a while after reboot and then just fails. I've tried reflashing CM 7 and clearing the caches and fixing the permissions. Any ideas how I could get it working again? If you need more details, please ask. Thank you!

Edit: Astro shows the sdcard folder permissions as "dr-"...is that what it should be?

Edited by fubar11, 06 November 2011 - 11:56 AM.

  • 0 Likes

technokid

technokid

Average Android

  • 4 posts

Posted 06 November 2011 - 01:05 PM #2

I'm having the same problem. Mine started right after i used and app to move apps to sd, I don;t know if it had anything to do with it or not..
  • 0 Likes

Bboy486

Bboy486

Average Android

  • 127 posts

Posted 06 November 2011 - 01:38 PM #3

This happened to me when I moved app to SD. Put your apps back on phone/tablet and it will not resume.
  • 0 Likes

technokid

technokid

Average Android

  • 4 posts

Posted 06 November 2011 - 06:51 PM #4

It will not allow me to move them back because it can't see them on the "SD" card. How did you do it?
  • 0 Likes

OP fubar11

fubar11

Average Android

  • 9 posts

Posted 07 November 2011 - 12:31 AM #5

Okay I got some updates on this one. Something definately went wrong with my sd card because my touchpad did not boot to Webos anymore. So I decided to wipe the whole thing and use the web doctor. Well, the web doctor hanged at 12 % everytime I tried it. I googled the issue and found out that using the novaterm command "dosfsck -r /dev/mapper/store-media" had helped someone so I tried it and I got it working, sort of.

Now my problem is that when I connect my usb to my win 7 pc in webos my computer says I need to format the usb drive. So apparently there's still something wrong with my sd card. Should I just format it? With the settings that win 7 suggest? Other than that my touchpad seems to be working fine...

EDIT: Okay could someone tell me what I should do to _completely_ get my Touchpad to factory condition?

EDIT2: Formatted with the default settings (quick format) on win 7 and also checked for errors (found none). Also did a full erase in Webos. Now everything seems okay but how can I be sure there are no errors/corruptions in my file system?

Edited by fubar11, 07 November 2011 - 02:55 AM.

  • 0 Likes

lee634

lee634

Android Beginner

  • 13 posts

Posted 08 November 2011 - 12:04 PM #6

I am having this issue as well, when i go to gallery it is saying sd card unmounted.
But when looking in the storage settings I have 22GB of space available.


Have tried to search for a solution but been unable.

Any ideas? please
  • 0 Likes

Redflea

Redflea

Supporting Member

  • 4,550 posts

Posted 08 November 2011 - 01:03 PM #7

Open terminal app.

type commands below - not the $ or # symbols.

$ su <enter>
# mount -o remount rw /mnt/sdcard<enter>

This will remount your SD card read/write.

Edited by Redflea, 08 November 2011 - 01:14 PM.

  • 3 Likes
Noob Guide to set up a build environment & build Touchpad (CM9/CM10) or Galaxy Nexus (Fruits-n-Veggies/Liquid/AOKP) ROMs: http://goo.gl/Zpht8

Samsung Galaxy Nexus (Toro): ROM: AOKP (personal builds): Kernel: Franco's Nightly (usually)
HP Touchpad: CM9 Homemade Kang based on Dalingrin and Co.

lee634

lee634

Android Beginner

  • 13 posts

Posted 08 November 2011 - 01:27 PM #8

Open terminal app.

type commands below - not the or # symbols.

su <enter>
# mount -o remount rw /mnt/sdcard<enter>

This will remount your SD card read/write.


Many thanks for that.
Worked a treat.

Is this a known fault with cm?
  • 0 Likes

Redflea

Redflea

Supporting Member

  • 4,550 posts

Posted 08 November 2011 - 01:47 PM #9

Yes...it's been reported by multiple users...some causes appear to be:

- Moving apps to SD card
- Launching Gallery app (You can download Quickpics and use that instead)
  • 0 Likes
Noob Guide to set up a build environment & build Touchpad (CM9/CM10) or Galaxy Nexus (Fruits-n-Veggies/Liquid/AOKP) ROMs: http://goo.gl/Zpht8

Samsung Galaxy Nexus (Toro): ROM: AOKP (personal builds): Kernel: Franco's Nightly (usually)
HP Touchpad: CM9 Homemade Kang based on Dalingrin and Co.

adobian

adobian

Member

  • 39 posts

Posted 08 November 2011 - 02:57 PM #10

SD card removed.... Restarting over 3 times. Another big reason why I bailed for now.
  • 0 Likes