Jump to content

  1. 0
  2. 0
  3. 0/5

Rate this Topic

- - - - -

New SLEEP OF DEATH BUG fix for CM7 that works for some

  • Please log in to reply

OP mortymouse

mortymouse

Average Android

  • 74 posts

Posted 15 October 2011 - 01:11 PM #1

Not sure if this is posted somewhere but this not only makes sense it works. Been running for over 24 hours, no sleep issues,etc. All credit where its due. I am just posting. This is from pre central boards.

http://rootzwiki.com...ll=1#post172055

Just wanted to make a quick note here about an important fix. The only showstopper bug I've run into on the touchpad running android is the "sleep of death". Basically, the pad goes to sleep and refuses to wake up, requiring a hard reboot (holding home/power for a long time etc).

The problem seems to stem from cpu scaling. It appears this alpha build is having trouble kicking itself in the pants when it scales down to 192mhz during sleep. Picking up cpu master from the app catalog lets you kick up the minimum scaling speed a few hundred megahertz. Putting it at 384 minimum seems to solve the issue.

It's not perfect obviously, since it'll drain a hair more power running at 384mhz, but it gets me past the only real showstopper bug I've encountered in android thus-far.


Above is the post, all credit where its due. This is from the Pre Central boards.

Edited by mortymouse, 16 October 2011 - 10:54 AM.

  • 0 Likes

mrandyp

mrandyp

Android Apprentice

  • 19 posts

Posted 15 October 2011 - 01:15 PM #2

You can edit title by first clicking edit post then click go advanced
  • 1 Likes
Apple MBP - 2.53 Intel Core 2 Duo, 4GB DDR3, OSX 10.7 Lion, Windows 7 Ultimate
Apple iPhone 4S - White
HP Touchpad - WebOS OC'd to 1.7ghz, Dual Booting Android CM7 OC'd to 1.5ghz

"if you're not first, you're last!"

Redflea

Redflea

Supporting Member

  • 4,550 posts

Posted 15 October 2011 - 01:21 PM #3

Not sure if this is posted somewhere but this not only makes sense it works. Been running for over 24 hours, no sleep issues,etc. All credit where its due. I am just posting. This is from pre central boards.

http://rootzwiki.com...ll=1#post172055


THIS IS FOR THE SLEEP ISSUE NOT WIFI.......I CANT EDIT TITLE
If a mod will please edit that would be great. Thanks.

Above is the post, all credit where its due. This is from the Pre Central boards.


This has been posted here multiple times already, but it doesn't hurt to publicize...I've been using this CPU setting and things have been SOD free lately....

But I don't think we can call this a fix yet, as one user had reported a SOD while using this setting, it may only minimize it. We'll get a real fix, hopefully, from the CM team in the near future.

Edited by Redflea, 15 October 2011 - 01:27 PM.

  • 1 Likes
Noob Guide to set up a build environment & build Touchpad (CM9/CM10) or Galaxy Nexus (Fruits-n-Veggies/Liquid/AOKP) ROMs: http://goo.gl/Zpht8

Samsung Galaxy Nexus (Toro): ROM: AOKP (personal builds): Kernel: Franco's Nightly (usually)
HP Touchpad: CM9 Homemade Kang based on Dalingrin and Co.

OP mortymouse

mortymouse

Average Android

  • 74 posts

Posted 15 October 2011 - 01:23 PM #4

Roger that
  • 0 Likes

Colchiro

Colchiro

Android Lover

  • 883 posts

Posted 15 October 2011 - 01:50 PM #5

I've only had one SOD since implementing this fix last night.
  • 0 Likes

neowiz73

neowiz73

tehk G33k

Posted 15 October 2011 - 02:19 PM #6

Tends to happen when it's left idle for over 3hrs. Which I only use it at home so I just shut it off when I'm not using it. It takes very little time to boot anyway.
But this works well for when I'm home all day and I use it on and off a lot.

sent from my HP Touchpad running CM7
  • 0 Likes

Zaphod-Beeblebrox

Zaphod-Beeblebrox

Just an older, more bitter version of Roman

Posted 15 October 2011 - 04:07 PM #7

to add to this fix, i used setcpu to make my screen off profile as indicated. left other profiles alone.
  • 0 Likes

Liner81

Liner81

Android Beginner

  • 4 posts

Posted 15 October 2011 - 04:31 PM #8

Ever since I started putting the pad to sleep using the sleep command button in the notification pane I've had no SOD problems. No messing with the CPU speeds.

(Button added under settings / cyanogenmod settings / interface / notification power widget)

I've also never had wifi problems, noticed I'm on channel 1, wifi sleep set to never since install.
  • 0 Likes

2-loc

2-loc

Android Apprentice

  • 21 posts

Posted 15 October 2011 - 04:33 PM #9

I've tried this fix when it was mentioned in another thread. It seems to have fixed sound crapping out/speaker popping when the screen goes dim/off also, anyone notice this also?
  • 0 Likes

easyguy

easyguy

Android Apprentice

  • 66 posts

Posted 15 October 2011 - 04:46 PM #10

is there a setting or app where if I press the volume button that will wake the TP up? I don't want to wear out the power and the middle button.
  • 0 Likes