Jump to content

  1. 0
  2. 0
  3. 0/5

Rate this Topic

- - - - -

[GUIDE] Making Fastboot work on 64-bit Windows 7 systems

  • Please log in to reply

OP ro6666lt

ro6666lt

Android Guru

  • 1,227 posts

Posted 13 September 2011 - 09:04 PM #1

I go through new laptops almost as fast as I break the glass on my NS4G. (Thank God for Best Buy's Replacement plan.) Anyways, it seems that there's an issue with a driver in the 2.3 SDK. After searching multiple places and then having to find those sources all over again every time i'm on a new laptop and phone, I decided I'd make it a little easier on the n00bs coming aboard running 64-bit windows 7.

THIS WILL WORK ON OTHER PHONES, AS WELL.

This isn't the only way to fix this, I'm sure... but it works. Do what you wish, just remember that I'm not responsible...blah blah blah...

Here we go:
  • download the Windows 7 x64 version of the PC software PdaNet.
  • Make sure your phone is disconnected from the computer. Extract and install PdaNet. Ignore the warning about HTC sync if you get it, it doesn't pertain to what we're trying to accomplish.
  • Towards the end of installation, PdaNet will prompt you to connect your phone. Enable USB debugging, if you haven't already done so.
  • Follow all of the prompts and accept the unverified driver warning. You might have to accept it more than once. After its finished, reboot your phone into fastboot mode.
  • Open the device manager in Windows. You should See, 'Android Phone' with 'Android adb interface' right below it, with no yellow exclamation marks.
  • ***If you do see a yellow exclamation mark, Right click and choose to update the driver manually. (C:\Program Files (x86)\PdaNet for Android\. You will see a warning about an unknown/unsigned driver. accept it.)***
  • Open a command prompt in the /tools directory and enter fastboot devices
  • You should see your phone's serial number listed below, confirming fastboot is working properly!
Hope this helps! Happy MoDding!!!

Edited by ro6666lt, 13 September 2011 - 09:12 PM.

  • 0 Likes