Jump to content

  1. 0
  2. 0
  3. 0/5

Rate this Topic

* * * * *
57 votes

[ROM][AOSP](3/9/14) Shiny ROM: OTA-Like, Stock Android [4.4.2] [KVT49L]

  • Please log in to reply

guma822

guma822

Member

  • 14 posts

Posted 06 August 2013 - 03:49 AM #5631

baldwinguy77, I noticed you recently updated the mod section and in the universal mods you put, "DSP Manager Add-on (DOES NOT WORK WITH ANDROID 4.3)". Now I discovered this the other day because it obviously isn't working for me. Is there any way to return this to normal? Or do I need to flash the Rom again? I tried to remove it and put it back and whatnot but no luck. Now NO equalizer works on my phone, I installed the app Equalizer and it says no audio effects available, also the one built into spotify doesnt work either, when I know it was working before I put DSP on.
  • 0 Likes

LTek1

LTek1

Member

Posted 06 August 2013 - 04:07 AM #5632

Facebook

Facebook

facebook


Anyone else wake up to a frozen Facebook update this morning?
  • 0 Likes

Stigy

Stigy

Android Lover

Posted 06 August 2013 - 05:26 AM #5633

Tiny and I have been talking about BLE back and forth and I don't think anyone has a definite answer yet. Of course the ROM includes the latest bluetooth stack and everything as it's all stock 4.3 source, but we don't know which devices officially support BLE through the new Android bluetooth stack. It's possible that the GNex doesn't have the hardware backend stuff necessary (yet) to use BLE. I'll let you know when I have more information.


I have proof that BLE works on the Galaxy Nexus.

I downloaded a scanner app that someone built and it locates my Fitbit One (also appears under Bluetooth options, which it didn't in 4.2.2). Unfortunately I can't pull data from it due to the Fitbit app not being updated to support the new 4.3 API, but undoing the commit linked below definitely enables BLE on the Galaxy Nexus.

https://android.goog...0e2b8663e2fb1b2

And here is the CM commit that someone used for me to test:
http://review.cyanog....org/#/c/46446/

I can post screenshots if needed.
  • 3 Likes

bouchigo

bouchigo

Android Enthusiast

Posted 06 August 2013 - 06:24 AM #5634

baldwinguy77, I noticed you recently updated the mod section and in the universal mods you put, "DSP Manager Add-on (DOES NOT WORK WITH ANDROID 4.3)". Now I discovered this the other day because it obviously isn't working for me. Is there any way to return this to normal? Or do I need to flash the Rom again? I tried to remove it and put it back and whatnot but no luck. Now NO equalizer works on my phone, I installed the app Equalizer and it says no audio effects available, also the one built into spotify doesnt work either, when I know it was working before I put DSP on.


You need to put the original lib and audio.conf files back where they belong, along with removing DSP manager (and remove any extra lib files that were added), that's most likely why nothing is working for you.

Edited by bouchigo, 06 August 2013 - 06:32 AM.

  • 2 Likes

Current Phone: LG G2 - Self-built Shadow Rom kk-4.4.2

Current Tablet(s):  Nexus 7 16GB (2012) - CM10.1.3, Nexus 7 32GB (2013) Stock, rooted, and unlocked

Retired Phone(s):  Droid X, Galaxy Nexus, SGS3

Retired Tablet(s):  HP Touchpad

 


guma822

guma822

Member

  • 14 posts

Posted 06 August 2013 - 06:35 AM #5635

You need to put the original lib and audio.conf files back where they belong, along with removing DSP manager (and remove any extra lib files that were added), that's most likely why nothing is working for you.


Thanks, but where would I find these files? Weren't they overridden by the installation of DSP manager?
  • 0 Likes

OP baldwinguy77

baldwinguy77

Shiny ROM

Posted 06 August 2013 - 07:24 AM #5636

Thanks, but where would I find these files? Weren't they overridden by the installation of DSP manager?

You need to put the original lib and audio.conf files back where they belong, along with removing DSP manager (and remove any extra lib files that were added), that's most likely why nothing is working for you.


You can wipe cache and dalvik cache and flash the ROM again and you should be good as new.

Can we get a working emoji apk?

Sent from my Galaxy Nexus using Tapatalk 4


The one in the OP doesn't work? What about Willyjay's mod?

Is it possible to get the QS+KillAll mod for 4.3 that doesn't force the brightness/volume slider to the top (even when checking it last)? I actually prefer it at the bottom. :-\

Sent from my Galaxy Nexus using Tapatalk 4

*edit - so actually, I guess I'm already getting used to it being at the top. :)


Haha well I can still look at moving it to the bottom, but if you're getting used to it I wouldn't want to confuse you again!
  • 0 Likes

Stigy

Stigy

Android Lover

Posted 06 August 2013 - 07:35 AM #5637

I can post screenshots if needed.


Found a place to upload them - the scan is finding my Fitbit One device.

I might try to write an app to connect to the GATT server, but it definitely does work on our devices. Not sure why Google disabled it in our builds.

Posted Image

Posted Image
  • 1 Likes

OP baldwinguy77

baldwinguy77

Shiny ROM

Posted 06 August 2013 - 07:40 AM #5638

Found a place to upload them - the scan is finding my Fitbit One device.

I might try to write an app to connect to the GATT server, but it definitely does work on our devices. Not sure why Google disabled it in our builds.


Thanks for all of the info. I'm not sure why Google disabled it either, so I'm going to look into it and hopefully find out. Just a little wary of enabling something that was deliberately disabled, but it might have just been a mistake. Thanks again as this is going to help a lot. I'll let you all know what I find out.

Edit: So maybe the only reason it isn't enabled is because it didn't get bluetooth SIG certified for it? Interesting.

Edited by baldwinguy77, 06 August 2013 - 07:47 AM.

  • 0 Likes

guma822

guma822

Member

  • 14 posts

Posted 06 August 2013 - 07:46 AM #5639

You can wipe cache and dalvik cache and flash the ROM again and you should be good as new.


Thanks much, I will give it a try when I get a chance
  • 1 Likes

Stigy

Stigy

Android Lover

Posted 06 August 2013 - 07:50 AM #5640

Thanks for all of the info. I'm not sure why Google disabled it either, so I'm going to look into it and hopefully find out. Just a little wary of enabling something that was deliberately disabled, but it might have just been a mistake. Thanks again as this is going to help a lot. I'll let you all know what I find out.

Edit: So maybe the only reason it isn't enabled is because it didn't get bluetooth SIG certified for it? Interesting.


I have a feeling that's the reason, but I am not sure why it didn't get certified. That is strange to me, but it would make sense. They disabled it on the 2012 Nexus 7 as well.

Just food for thought - let me know (PM me) if you'd like to do any testing if you have a test build or something. I can look into building an app to read the Fitbit data tonight or tomorrow, but hoping Fitbit updates their app soon as well.
  • 1 Likes