Jump to content

  1. 0
  2. 0
  3. 0/5

Rate this Topic

* * * * *
3 votes

[Tutorial] How to Turn Off Capacitive Buttons + Lights and Use On Screen Nav

  • Please log in to reply

OP Adam Metzner

Adam Metzner

Android Lover

Posted 25 July 2012 - 09:31 PM #1

I have seen a bunch of posts regarding the capacitive buttons and on screen navigation buttons. Love them or hate them, this is how you can turn them off.

First off the only way right now (that I know of) to get on screen nav buttons is AOKP. I will leave that up to you on how to get that installed.
As for turning off the capacitive buttons this is how I did it.
1.On AOKP go to Settings>Navigation bar>Enable bar. If you don't do this first you wont have a way to navigate when the capcitive buttons are off.
2. Download a root file explorer. Root Browser Lite --> http://goo.gl/b9ISW This is what I will use.
3.Load up Root Browser and navigate to system>usr>keylayout. We will be looking for a file called "sec_touchkey.kl".
4. Select it and hit "Open as..." then "Text file" then "RB Text Editor"
5. Now we see this:
key 139		VIRTUAL
key 158	 VIRTUAL
key 102   HOME
key 217   SEARCH
All you have to do is option out the keys you don't want to work with a #. So if you are like me and think the home button is fine, it will look like this.
#key 139		VIRTUAL
#key 158	 VIRTUAL
key 102   HOME
key 217   SEARCH
6. When you have the ones you want optioned out just tap the little disk icon in the top right. It will ask for root rights, grant it, saved.
7. Now just reboot and DONE!

Your keys should no longer work. They will still light up, but you cant use them.

Now onto the lights. Fellow Rootzwiki frequenter Jaxidian came up with this little work around and was kind enough to share it.

1. Go into Settings -> Display -> Custom Backlight Settings -> Edit other levels... -> And set every "button" field to 0 and save.
2. Turn your brightness settings to "Auto" either via your statusbar widgets/toggles or via the standard Settings -> Display settings.
3. Go back to Home, turn your screen off, wait a second and turn it back on. Notice that the button lights stay off! :-)
If you like to keep keep your screen brightness at Auto, then you're done! :-)
4. Now turn your brightness back to a manual setting. Notice that your buttons light back up. :-( That's okay.
5. Turn your screen off, wait a few seconds, then turn it back on.
6. Now they should be off and will remain off until either you reboot or you toggle the Auto field again (which toggling it simply brings you back to step 5 to fix again).

Thanks Jax!
Hope this helps anyone that hates the capacitive buttons or just misses the on screen nav from the Gnex like I did. If I missed anything please let me know. Cheers!

Edited by Adam Metzner, 26 July 2012 - 12:37 PM.

  • 5 Likes

DroidOnRoids

DroidOnRoids

Everybody! Mosh Pit!

Posted 26 July 2012 - 01:36 AM #2

Adam, awesome tutorial! Now folks can turn their S3 into a Gnex again! Thanks!
  • 0 Likes

corenojc

corenojc

Android Enthusiast

  • 145 posts

Posted 26 July 2012 - 03:05 AM #3

This is pretty good stuff Allen. Its easy to read and understand. Keep up the good work.
  • 0 Likes

Jaxidian

Jaxidian

teh Jax

Posted 26 July 2012 - 09:44 AM #4

Perfect except for the button lights staying on (as you already noted). Fortunately, this even seems temporarily fixable (until you reboot).

Do this:
  • Go into Settings -> Display -> Custom Backlight Settings -> Edit other levels... -> And set every "button" field to 0 and save.
  • Turn your brightness settings to "Auto" either via your statusbar widgets/toggles or via the standard Settings -> Display settings.
  • Go back to Home, turn your screen off, wait a second and turn it back on. Notice that the button lights stay off! :-)
    If you like to keep keep your screen brightness at Auto, then you're done! :-)
  • Now turn your brightness back to a manual setting. Notice that your buttons light back up. :-( That's okay.
  • Turn your screen off, wait a few seconds, then turn it back on.
  • Now they should be off and will remain off until either you reboot or you toggle the Auto field again (which toggling it simply brings you back to step 5 to fix again).

Not perfect but very easy. :-)
  • 0 Likes

OP Adam Metzner

Adam Metzner

Android Lover

Posted 26 July 2012 - 11:09 AM #5

Jax. Did you do your method after disabling the keys? Because when I first installed AOKP I turned off the lights, then I turned off the buttons and they lit back up. Not sure if the light mod has something to do with the keymapping or not. How long did it take you to figure that out? Crazy option changes. Good work!
  • 0 Likes

Jaxidian

Jaxidian

teh Jax

Posted 26 July 2012 - 12:00 PM #6

Jax. Did you do your method after disabling the keys? Because when I first installed AOKP I turned off the lights, then I turned off the buttons and they lit back up. Not sure if the light mod has something to do with the keymapping or not. How long did it take you to figure that out? Crazy option changes. Good work!


I followed your steps and then started playing with ways to disable the lights. I actually stumbled upon it pretty quickly. I noticed that the "Current Value" in the "Edit other levels" screen said -1 and then my thought process went like this: "If it thinks it's -1 bright outside, how can it adjust the brightness dynamically? Hmm, I bet that's because I have it set to manual. i wonder what it does if I go to Auto - it should use these values then. Oh, hey, the light goes out, as expected. Well, at least it works on Auto - back to 100% we go. Yup, here they come back, darn." And then I went to write all of this up. Before I hit Submit, i turned my phone back on and noticed the lights then stayed out. I rebooted and back they came. I reproduced a few times and then altered my post before hitting submit, and there you have it! So yeah, it was luck. :-)
  • 0 Likes

OP Adam Metzner

Adam Metzner

Android Lover

Posted 26 July 2012 - 12:03 PM #7

I followed your steps and then started playing with ways to disable the lights. I actually stumbled upon it pretty quickly. I noticed that the "Current Value" in the "Edit other levels" screen said -1 and then my thought process went like this: "If it thinks it's -1 bright outside, how can it adjust the brightness dynamically? Hmm, I bet that's because I have it set to manual. i wonder what it does if I go to Auto - it should use these values then. Oh, hey, the light goes out, as expected. Well, at least it works on Auto - back to 100% we go. Yup, here they come back, darn." And then I went to write all of this up. Before I hit Submit, i turned my phone back on and noticed the lights then stayed out. I rebooted and back they came. I reproduced a few times and then altered my post before hitting submit, and there you have it! So yeah, it was luck. :-)


Good stuff!
  • 0 Likes

Jaxidian

Jaxidian

teh Jax

Posted 26 July 2012 - 12:05 PM #8

Good stuff!


BTW, copy/paste/steal my steps all you want for your guide and make it your own. Make this the go-to thread for these steps and don't worry about "taking credit" from me - it's all yours anyways. I only found them because I thought this might be a good guide to tweet but wanted to try it first. ;-)
  • 1 Likes

OP Adam Metzner

Adam Metzner

Android Lover

Posted 26 July 2012 - 12:35 PM #9

BTW, copy/paste/steal my steps all you want for your guide and make it your own. Make this the go-to thread for these steps and don't worry about "taking credit" from me - it's all yours anyways. I only found them because I thought this might be a good guide to tweet but wanted to try it first. ;-)


Done and done sir! Thanks!
  • 0 Likes

corenojc

corenojc

Android Enthusiast

  • 145 posts

Posted 26 July 2012 - 01:15 PM #10

Credit him man. Even though he doesn't mind, its the right thing to do. Deep down I think you know that.
  • 0 Likes