Jump to content

  1. 0
  2. 0
  3. 0/5

Rate this Topic

- - - - -

[RESOLVED] Jelly Bean/Nexus: Pics out of order, Date Taken EXIF data missing - looking for a fix

  • Please log in to reply

OP Redflea

Redflea

Supporting Member

  • 4,550 posts

Posted 12 July 2012 - 11:07 PM #1

UPDATE: 7/17/2012

Google has posted on the issue thread that they are aware of this defect and will be pushing out a fix. Timing is not clear, nor is if the fix will cover both JB and ICS, or just JB. See the responses from Google below.

We have a fix for this bug in the internal codebase, and it will be pushed out to devices in the next update.

The fix hasn't been open-sourced yet; while I don't know details of the release plans, I'd expect it to become public in the next public code push, roughly at the same time as when the next device updates go out.

Thread is here...someone already posted to ask about 4.0.4 getting the update as well...

http://code.google.c...ars#makechanges

=========================================
Before I go ballistic on my phone and wipe the SD card, wanted to see if anyone else has this issue and has found a fix...

The Gallery on my phone keeps thinking that photos are dated several days (four or five days or more) newer than they are.

So pics I've taken on July 4th are shown as July 8th (or 9th), others taken on the 12th are reported as July 16th (yeah, that date hasn't even happened yet, but Gallery reports that my pics are that date). I'm time traveling! :)

QuickPics, another gallery app, reports and sorts the photos correctly, so this is a quick of the Android Gallery not seeing the date info correctly.

So if I take a picture right now it shows up with the right date in the Gallery, dated July 12th, but at some point the Gallery gets confused and reports some subset of pics with the wrong dates. For instance, pics taken on 6/17 are properly sorted/dated by the Gallery, but photos from June 30th are reported to be from July 4th. SO I take a pic now, it shows up in the little just taken icon in the top right of the camera UI, but if I swipe to the left to see the most recently taken photo I'll see several images from several days ago first (with Gallery thinking they are dated sooner than the one I just too), and then the pic I just took will finally appear.

<EDIT> Also just noticed that all of the pics from my phone created 6/30 or later have no EXIF data for Date Taken - when I look at their exif Date Taken properties in Win7 it's just blank. Not good...

Has anyone else who's experienced this found a fix? This has persisted across both dirty and clean (wipe system/caches/factory reset) installs, and clearing caches and data for Gallery in Settings>Apps>All.

My next step it do a full wipe of the SD card, but if the issue is a bug in Gallery that could be a waste of time, so wanted to see what other's experience with this has been (or am I mostly alone)... :) <eek!> I've seen a couple others report this who were on other ROMs...

Thanks!

Edited by Redflea, 17 July 2012 - 10:26 AM.

  • 0 Likes
Noob Guide to set up a build environment & build Touchpad (CM9/CM10) or Galaxy Nexus (Fruits-n-Veggies/Liquid/AOKP) ROMs: http://goo.gl/Zpht8

Samsung Galaxy Nexus (Toro): ROM: AOKP (personal builds): Kernel: Franco's Nightly (usually)
HP Touchpad: CM9 Homemade Kang based on Dalingrin and Co.

TooLegit

TooLegit

Sith

  • 62 posts

Posted 12 July 2012 - 11:32 PM #2

which ROM are u running? I am running vicious JB v3 and luckily do not have that problem. Hopefully a fix can be worked out.
  • 0 Likes
Toro AOKP JB Build 1

Lets both get some extra storage. use this link and sign up for dropbox http://db.tt/5PXbqmbh

I Am Marino

I Am Marino

Thriller

Posted 13 July 2012 - 01:45 AM #3

Just stick with Quickpic, much better anyway.

Sent from my Galaxy Nexus using Tapatalk 2
  • 1 Likes
-Nexus 4-
ROM: AOKP MR1
Kernel: Trinity

OP Redflea

Redflea

Supporting Member

  • 4,550 posts

Posted 13 July 2012 - 07:26 AM #4

TooLegit - this is on DroidVicious JB Port (versions 1 and 5) and DroidVicious 4.1.1 AOSP.

Just stick with Quickpic, much better anyway.

Sent from my Galaxy Nexus using Tapatalk 2


That's not an option, as far as I can tell, within the Camera app when using the new and very cool option to swipe left to see the pics you've just taken. If I could just switch and use Quickpic I probably would, but the stock Camera and Gallery appear to be joined at the hip.

Also, there are some things wrong w/the exif data on the images, and I'd like to fix that regardless. I've just noticed that on the pics from the Nexus that I've copied to my computer last night, any pic taken from June 30 or later has no exif data for Date Taken - it's just blank. When I check file properties in Win7 on those images there is no info there. All the other images from the camera before 6/30 do have the Date Taken exif info intact. That matches up w/what I was reporting above in terms of which images Gallery was reporting the wrong date. I'm assuming that the only reason QuickPic is getting it "right" is that it must be using Date Created for its date sorting/reporting.

This is getting odder and odder...
  • 0 Likes
Noob Guide to set up a build environment & build Touchpad (CM9/CM10) or Galaxy Nexus (Fruits-n-Veggies/Liquid/AOKP) ROMs: http://goo.gl/Zpht8

Samsung Galaxy Nexus (Toro): ROM: AOKP (personal builds): Kernel: Franco's Nightly (usually)
HP Touchpad: CM9 Homemade Kang based on Dalingrin and Co.

RickRom

RickRom

Android Lover

  • 230 posts

Posted 13 July 2012 - 07:30 AM #5

I have seen this problem also, but I haven't figured out how to fix it yet. Do you have yours set to save location also?
  • 0 Likes
Verizon Galaxy Nexus 4G LTE | Paranoid Android v2.XX | JB 4.1.2 | V.FF02 / FG02 | Leankernel v4.X.X | TWRP 2.3.1.0

chronophilos

chronophilos

Average Android

Posted 13 July 2012 - 07:48 AM #6

I have the same issue. 4.1.1 Build number JRO03C. I don't know what triggers it, but it seems to be related to sharing photos from the gallery app into other apps like instagram or google+. Pictures that would be shown with a 7/5 date today might change tomorrow to 7/18 or something like that. It makes the gallery unusable. I had the problem in 4.1. as well (I had done a completely clean install from 4.0.4). From 4.1 to 4.1.1. I only wiped cache and dalvik cache.
  • 0 Likes

OP Redflea

Redflea

Supporting Member

  • 4,550 posts

Posted 13 July 2012 - 07:49 AM #7

I have seen this problem also, but I haven't figured out how to fix it yet. Do you have yours set to save location also?


Normally yes, but I forgot to turn that back on when I did a clean install of 4.1.1 AOSP, so it is off at the moment. But looking at the pics affected, it doesn't appear that having location info on or off has any affect on this issue. Pics with location info are in both the group of pics w/correct date taken data, and pics in the group where date taken data is missing...
  • 0 Likes
Noob Guide to set up a build environment & build Touchpad (CM9/CM10) or Galaxy Nexus (Fruits-n-Veggies/Liquid/AOKP) ROMs: http://goo.gl/Zpht8

Samsung Galaxy Nexus (Toro): ROM: AOKP (personal builds): Kernel: Franco's Nightly (usually)
HP Touchpad: CM9 Homemade Kang based on Dalingrin and Co.

OP Redflea

Redflea

Supporting Member

  • 4,550 posts

Posted 13 July 2012 - 07:57 AM #8

I have the same issue. 4.1.1 Build number JRO03C. I don't know what triggers it, but it seems to be related to sharing photos from the gallery app into other apps like instagram or google+. Pictures that would be shown with a 7/5 date today might change tomorrow to 7/18 or something like that. It makes the gallery unusable. I had the problem in 4.1. as well (I had done a completely clean install from 4.0.4). From 4.1 to 4.1.1. I only wiped cache and dalvik cache.


Thanks...I'm not sure my experience is consistent with that, as I have had this issue w/images that I haven't shared/touched or done anything with other than just taking them - it affects 118 images, and in some cases just a few pictures from a larger set of pics taken on a particular date are affected! <double-eek!>

So are you saying the only images that have this problem on your phone are ones you've shared from the Gallery?
  • 0 Likes
Noob Guide to set up a build environment & build Touchpad (CM9/CM10) or Galaxy Nexus (Fruits-n-Veggies/Liquid/AOKP) ROMs: http://goo.gl/Zpht8

Samsung Galaxy Nexus (Toro): ROM: AOKP (personal builds): Kernel: Franco's Nightly (usually)
HP Touchpad: CM9 Homemade Kang based on Dalingrin and Co.

nao.nozawa

nao.nozawa

Android Beginner

Posted 13 July 2012 - 09:38 AM #9

I've also had this happen to me a few times with the Vicious Jelly Bean ROMs (V3 through V5). It only seems to happen to one picture at a time on my phone, though.
  • 0 Likes

OP Redflea

Redflea

Supporting Member

  • 4,550 posts

Posted 13 July 2012 - 11:10 AM #10

Just noticed a couple of other (related?) issues:

If I connect to my phone in PTP mode, I can select to display image attribute columns in the Details view (things like Date Taken, Dimensions), but no data from the image files is displayed, they all show blank for Date Taken, Date Created, Dimensions, etc....This is all of them showing now info, even the ones that really do have the Date Taken info in their EXIF headers.

In MTP mode those headers are not available, Windows thinks every file/folder is for audio/video only, and only displays those column options (artist/track/length, etc.).

DIdn't look into this before JB, so no idea if it was like this on ICS as well, but it's a mess as far as I can tell...unless this is a "just me" issue.
  • 0 Likes
Noob Guide to set up a build environment & build Touchpad (CM9/CM10) or Galaxy Nexus (Fruits-n-Veggies/Liquid/AOKP) ROMs: http://goo.gl/Zpht8

Samsung Galaxy Nexus (Toro): ROM: AOKP (personal builds): Kernel: Franco's Nightly (usually)
HP Touchpad: CM9 Homemade Kang based on Dalingrin and Co.