Jump to content

  1. 0
  2. 0
  3. 0/5

Rate this Topic

- - - - -

The Droid:Bionic can do CMDA/4LTE and GSM/HSPA+ [IMAGE INTENSIVE]

  • Please log in to reply

OP AlexWekell

AlexWekell

Member

  • 12 posts

Posted 08 May 2012 - 10:07 PM #1

Posted Image
Posted Image
Posted Image
Posted Image
Posted Image
Posted Image
Posted Image
Posted Image
Posted Image
Posted Image
  • 2 Likes

projektorboy

projektorboy

Member

Posted 12 May 2012 - 01:51 PM #2

Are you going to post a download link to RadioComm with the instructions on how to enable the feature, or the flashable ZIP that does the NVRAM edit to the radio?

Edit: Just gonna do this myself.

ALL WORK AND INFORMATION IS FROM TEAM BLACK HAT. NONE OF THIS IS MINE. ALL CREDIT GOES TO THAT BRILLIANT TEAM

What you will need:

>A Droid Bionic that's been updated to the leaked 5.9.904
>RadioComm 11.12.2 or newer - Download Here
>Updated Motorola USB Drivers - Download Here

I recommend that you be as completely stock as possible. However I have been able to test this successfully on Eclipse 2.2. Whether you're rooted or not is irrelevant, as you're editing the NVFlash of the radio firmware, and not the ROM itself.

I also found with my testing that Team Gummy's ICS ROMs have a nasty allergic reaction to this hack after you put in a Non-Verizon SIM card. Be warned.

The Steps (Credit to TBH)

1. Ensure USB is connected as PC Tools mode (not Mass Storage)
2. In Radiocomm go to MA->CDMA1X->QSC60x5
3. After it comes up, switch to FTM Common1 tab and wait for the phone to enumerate purple (or green).
4. On the upper right side in the NVAccess, scroll to NV item 1877 NV_RF_BC_CONFIG_I
5. Read the value from the device
6. Replace the first 8 bytes (16 digits) with: 8703E80400000200
7. Write the data to the device and powercycle.
This will enable GSM/UMTS bands.

To disable GSM/UMTS, perform the same 7 steps, but replace the 8-byte data with: 0700000000000000

AFTER SOME WHILE GSM SIGNAL IS STRONG FOR VOICE BUT NO DATA


Notes & Other Observations

After you've powercycled, the only way that you will be able to switch between CDMA/LTE for Verizon and GSM/UMTS for others is by going to the dialer and doing *#*#4636#*#*. WCDMA Preferred will be what gets GSM networks going on the Bionic. If you try going to Settings > Wireless and Networks you'll be met with a bunch of FC's and an inability to change settings. This is normal and happens to everyone.

When it comes to AT&T & T-Mobile SIM cards, I've noticed that pre-paid plans seems to work more often than post-paid plans. My AT&T GoPhone SIM works immediately when I switch over. I've tried 4 different TMo SIM cards on postpaid plans and they refuse to authenticate to the network.

On AT&T you'll be able to get data in the form of EDGE (2G) and UMTS (3G) but not HSPA+ (their "4G"). On T-Mobile, due to their strange usage of 1700Mhz, you will only be able to do EDGE data.

This hack is reportedly working on the D4 and Razr but I have no way of confirming or denying that. Go check D4 and Razr forums. Your mileage may vary.

Below pictures are from when I was running Eclipse 2.2 with the .904 baseband


Posted Image
Posted Image
Posted Image

Edited by projektorboy, 13 May 2012 - 08:06 AM.

  • 0 Likes

nenedy

nenedy

Average Android

  • 1 posts

Posted 28 August 2012 - 12:50 PM #3

Hello!
Hello, I live in Brazil and bought a Bionic Ebay. I tried to put the chip in my carrier and msg is "The sim card is from an unknow source". Did the procedures described in this forum, but still not getting anywhere, the bar singals bars are showed with a signal of forbidden on top.
Thx
  • 0 Likes

nomane

nomane

Average Android

  • 1 posts

Posted 17 April 2014 - 09:13 PM #4

try this way. it is easier and safer.
1. registrate on and cdmatool.com download new dfs on (its free)
2. in dfs go to programming/band and check all standards that you need.

3. click on Write button and restart phone

 

rf bc config cdmatool.PNG


Edited by nomane, 17 April 2014 - 09:17 PM.

  • 0 Likes