Jump to content

  1. 0
  2. 0
  3. 0/5

Rate this Topic

- - - - -

how i fixed my wifi in ICS

wifi issue ics sensation
  • Please log in to reply

OP loolooyyyy

loolooyyyy

Average Android

  • 2 posts

Posted 24 March 2012 - 04:15 PM #1

no matter what i did (maybe downloaded up to 5 different ICS ROM , 3Kernels , all the radios, whit every possible combination of them)
i couldn't turn wifi on, though it was mentioned in forums the problem is fixed in new roms
so...

extract the file "wpa_supplicant" located on /system/bin from 'a rom with working wifi, i.e cm7 alpha 10
install your new rom , backup the old file (as it is needed) and replace it with extracted wpa_supplicant , set it's permission to 0755 ( -rwxr-xr-x )
reboot, remove wpa_supplicant.conf again, try to connect, it wont
recover the old wpa_supplicant file with the same permissions
reboot
remove wpa_supplicant.conf again, try to connect, it connects
in next reboot if it doesn't connect correct the wpa_supplicant.conf permission to 0666 ( -rw-rw-rw- )
it connects

ok it sound crazy, i am crazy, but looking at logcat realized wpa_supplicant (bin file, not conf) was generating a lot of error, thought maybe the old one works, again looking at logcat i realized it was simply worse it couldn't even run, recovered the old one, and corrected wpa_supplicant permissions, it connected like a charm, but after every reboot wpa_supplicant.conf permission returns to 0660, which i don't really mind since it works at least

if anyone has a logical explanation, i'd be very very happy to hear, i'm afraid i might encounter the same problem in official CM9

(i tried it on two roms, virtuous inquisition 4.0.0 and the one by vorbeth(based on CM) both having overclocked kernel by sebastianFM and the method worked)
  • 0 Likes

Little__Ducky

Little__Ducky

Average Android

Posted 17 May 2012 - 08:31 AM #2

I am going to try this now. I haven't had WiFi since OTA update which i thought was weird, I checked my antennae pins, flashed several ROMS, Factory resets, Downgraded back to GB, Changed my Radio/RIL, Upgraded and Downgraded RUUs. Hopefully THIS works! I have no warranty so if it's a hardware issue I'm S.O.L ! Thank you for this post. Will report back!
  • 0 Likes

Little__Ducky

Little__Ducky

Average Android

Posted 17 May 2012 - 08:48 AM #3

I may be doing something wrong. How do I set permissions in numbers? When I long press and click permssions it only gives me the option to toggle read/write/execute.
  • 0 Likes

OP loolooyyyy

loolooyyyy

Average Android

  • 2 posts

Posted 17 May 2012 - 12:03 PM #4

new method:
i still say, the first method seems totally crazy, unrelated, BUT it worked on virtuous! i dont know why....
now i'm using opensensation, i'm using this method:

create a text file , called wifi.sh
copy this in it:

sqlite3 /data/data/com.android.providers.settings/databases/settings.db "INSERT INTO secure (name, value) VALUES ('wifi_country_code', 'EN');"

now run the file as su like this, in terminal:
su
sh wifi.sh

turn wifi off/on, it's working!
  • 0 Likes

ErnestoD

ErnestoD

Average Android

  • 1 posts

Posted 18 November 2012 - 11:08 AM #5

Hy Im having the same issue as U.
I cant activate wifi. I did everythin and I just find this site.
Could U please explain me a little bit how to create this file and install
Thanks

new method:
i still say, the first method seems totally crazy, unrelated, BUT it worked on virtuous! i dont know why....
now i'm using opensensation, i'm using this method:

create a text file , called wifi.sh
copy this in it:

sqlite3 /data/data/com.android.providers.settings/databases/settings.db "INSERT INTO secure (name, value) VALUES ('wifi_country_code', 'EN');"

now run the file as su like this, in terminal:
su
sh wifi.sh

turn wifi off/on, it's working!


  • 0 Likes