Jump to content

  1. 0
  2. 0
  3. 0/5

Rate this Topic

- - - - -

[GUIDE]Galaxy Nexus MTP and Ubuntu or Mint Linux File Transfer

mtp galaxy nexus linux ubuntu linux mint file transfer
  • Please log in to reply

OP loveubuntu

loveubuntu

Average Android

Posted 16 March 2012 - 06:34 AM #1

Here is how you do it courtesy of Shannon VanWagner

and his website Humans Enabled


Thanks Shannon. Here is the what you should do: again all credit goes to Shannon VanWagner. Fire up a terminal session:

1-
sudo apt-get install libusb-dev

2- download libmtp tar.gz from http://sourceforge.n.../files/libmtp/

3-cd to the directory you downloaded to: Download in this case, case sensitive

cd Download

4- extract the tar package

tar xvf libmtp-1.1.1.tar.gz

please make sure you check the file version, this file changes as it is updated and change it accordingly per the above website

5- cd to the newly created folder that has the extracted file:

cd libmtp-1.1.1

again don't forget to change the name if the version has changed

6- compile and install: do each step separately

./configure --prefix=/usr

make

sudo make install

7- while in the same directory in the terminal, copy the rules from there to the udev folder:

sudo cp 69-libmtp.rules /etc/udev/rules.d

8- install gMTP:

sudo apt-get install gmtp

9- open up gMTP, go to edit/prefrences and check the box for Always Show Download Path. This way when you are downloading from the phone to your computer, you are asked to choose a location. Use the Add button to upload from your Linux Box to the phone. Delete does, well, Delete a file.
  • 0 Likes

tb7andro

tb7andro

Android Lover

  • 175 posts

Posted 16 March 2012 - 08:08 AM #2

Thanks for this, but whenever I go to open up gMTP on Ubuntu 11.10, and I do add/search for devices the program freezes and then closes. I also used 1.2 instead of 1.1 mtp libs<br /><br />Sent from my Galaxy Nexus using RootzWiki

Edited by tb7andro, 16 March 2012 - 08:09 AM.

  • 0 Likes

bridaddy69

bridaddy69

Old Fart

  • 108 posts

Posted 16 March 2012 - 08:07 PM #3

Seriously try out qtadb it works awesome. Its basically an adb based file explorer and then some.
  • 1 Likes

Posted Image


yarly

yarly

Just a noob that doesn't know what he's talking about

Posted 16 March 2012 - 08:12 PM #4

As an alternative, you can do something like

1) get this https://play.google....re=related_apps or use dropbear on the terminal

2) set it up and run it

3) in your linux desktop in the folder bar for switching folders, type:

sftp://username:password@your-android-ip-address-over-wifi



After that, you can transfer files over wifi from your computer to android securely or from android to your computer (including your filesystem outside of the "sdcard").

Edited by yarly, 16 March 2012 - 08:19 PM.

  • 0 Likes

mightybrick

mightybrick

Super User

Posted 16 March 2012 - 08:48 PM #5

Seriously try out qtadb it works awesome. Its basically an adb based file explorer and then some.

Thanks for making this suggestion. After messing with it for a day, I finally got it working. Had to "chmod +x QtADB" to get it to run. Took me a while to figure that out. :P
  • 0 Likes

housry23

housry23

Android Apprentice

Posted 11 May 2012 - 04:20 AM #6

I am running Ubuntu 12.04 64 bit and everything seemed to compile and I have the 69-libmtp rules file in the etc/udev folder, but gMTP will still not connect with my GNex. I can use Wifi File Explorer, but would really like to set this up to work properly. I tried the 1.1.3 libmtp and that just threw errors in the make command, so I tried 1.1.2 and it compiled, but gMTP still doesn't see my GNex. Any help would be much appreciated. I'm a bit of a Ubuntu noob, so please be nice.
  • 0 Likes
Download Linux Mint 13 http://www.linuxmint.com/

barcodelinux

barcodelinux

Android Apprentice

  • 86 posts

Posted 20 June 2012 - 05:26 PM #7

Seriously try out qtadb it works awesome. Its basically an adb based file explorer and then some.

Agreed. Much better solution.
  • 0 Likes