Jump to content

  1. 0
  2. 0
  3. 0/5

Rate this Topic

* * * * *
18 votes

CyanogenMod9 for O2X and G2X (SelfKANG3)

  • Please log in to reply

xzatx

xzatx

Average Android

  • 1 posts

Posted 27 March 2012 - 02:22 PM #581

It works awesome, my X2 feels like a new phone, im loving it.

Thanks allot to selfkang.
  • 0 Likes

csh

csh

Average Android

  • 2 posts

Posted 28 March 2012 - 08:47 AM #582

Thanks a lot for your great work!

Note: Matching source is, as usual, in CM's github.

How can I build this from source? Doing
$ . build/envsetup.sh && brunch p990
in the github ICS branch results in
build/core/product_config.mk:189: *** _nic.PRODUCTS.[[device/*/p990/cm.mk]]: "device/lge/star-common/star.mk" does not exist. Stop.
Device p990 not found. Attempting to retrieve device repository from CyanogenMod Github (http://github.com/CyanogenMod).
Found repository: android_device_lge_p990
CyanogenMod/android_device_lge_p990 already exists
Syncing repository to retrieve project.
Repository synced!
Looking for dependencies
Dependencies file not found, bailing out.
Done
build/core/product_config.mk:189: *** _nic.PRODUCTS.[[device/*/p990/cm.mk]]: "device/lge/star-common/star.mk" does not exist. Stop.
** Don't have a product spec for: 'cm_p990'
** Do you have the right repo manifest?
No such item in brunch menu. Try 'breakfast'
The ICS branch of the kernel (lge-kernel-star) builds fine.

Thanks for any help.
  • 0 Likes

csh

csh

Average Android

  • 2 posts

Posted 30 March 2012 - 05:15 PM #583

build/core/product_config.mk:189: *** _nic.PRODUCTS.[[device/*/p990/cm.mk]]: "device/lge/star-common/star.mk" does not exist. Stop.


Found it. Pretty much nothing works, but at least it's 404 ;)

Posted Image
  • 0 Likes

Dralan

Dralan

Average Android

  • 8 posts

Posted 31 March 2012 - 12:24 PM #584

Has anyone experienced Google maps navigation having the maps screen turn gray after a while of use? This happens to me a lot while using navigation and playing music. I can see the top part of where I need to turn next, but the map screen turns gray.

Sent from my LG-P999 using Tapatalk
  • 0 Likes

BigRedd

BigRedd

Average Android

  • 1 posts

Posted 31 March 2012 - 08:16 PM #585

Has anyone experienced Google maps navigation having the maps screen turn gray after a while of use? This happens to me a lot while using navigation and playing music. I can see the top part of where I need to turn next, but the map screen turns gray.

Sent from my LG-P999 using Tapatalk


Yeah, that happens to me all the time, I think it's because it's taking advantage of some sort of ICS-native functionality, like what was mentioned in the initial post:

Most visible Known issues:
- Apps made for Android 4 with their own specific graphics implementations (Chrome is a good example) will be glitchy. Please do not submit bug reports to those apps' authors.


Edited by BigRedd, 31 March 2012 - 08:16 PM.

  • 0 Likes

Dralan

Dralan

Average Android

  • 8 posts

Posted 31 March 2012 - 09:49 PM #586

Hopefully it will be fixed in the next build. I like ICS too much to go back!

Sent from my LG-P999 using Tapatalk
  • 0 Likes

nickdelf

nickdelf

Average Android

  • 2 posts

Posted 31 March 2012 - 10:16 PM #587

Does anyone know whether you can actually buy a ROM such as this? I love the offering but would prefer it if the provider were committed to updates, new versions etc., rather than us simply relying on his good nature, time available, and charity?

N
  • 0 Likes

Matteo

Matteo

Member

Posted 01 April 2012 - 01:47 AM #588

There is no place where you can buy (wtf?) better ROM than this because it can't be done at the moment. Any advance in development relies on NVIDIA and/od LG. Once Ricardo has needed sources, he will repair video codec and CM robot will be pleased to bake you a new nightly build every day ;) It takes time just because NVIDIA and/or LG sux :D
  • 1 Likes

nickdelf

nickdelf

Average Android

  • 2 posts

Posted 04 April 2012 - 05:44 AM #589

Is this what I should expect from this ROM?

Posted Image
  • 0 Likes

Dralan

Dralan

Average Android

  • 8 posts

Posted 08 April 2012 - 10:58 PM #590

Mine was like that too at first... actually worse until I reset battery statistics. Today I had light to moderate use for about 15 hours and I'm at 50% as I'm writing this. I'd post a screenshot but I rebooted about 6 hours ago to adjust my jvm heap to see if that makes any difference (something I read in another thread).

Sent from my LG-P999 using Tapatalk
  • 0 Likes