Jump to content

  1. 0
  2. 0
  3. 0/5

Rate this Topic

* * * * *
1 votes

[TOOL][Updated 2.22.12]viperMOD PrimeTime v4.5 | Auto Root/Unroot/Busybox/CMW Flash!

  • Please log in to reply

OP -viperboy-


Android Beginner

  • 47 posts

Posted 04 January 2012 - 01:32 AM #1

Mod Type:: Mod

Difficulty:: Very Easy

Mod Base:: Other

Mod Status:: Stable

Apply In:: Other (See Description)

Carrier:: N/A

Optional:: Includes Recovery

Requires Root:: No

Android Version:: 4.0.2 (ICS)


Posted Image

Posted ImagePosted Image
Posted ImagePosted Image

PrimeTime Reviews

Tried the other two methods without any success...but this one is the only one that works!!

You have done great work here. Top notch, the crazy thing is, even after trying to root about 6 times and being unsuccessful, I wasn't at all worried when I started PrimeTime.

Everything went great I had lost root during the ICS ota and this fixed everything. Thanks -viperboy-

Asus should send you a commission check, PrimeTime is the only reason I didn't return the TFP today!!! Thanks again!!!

Introducing viperMOD PrimeTime! An automated rooting program for your Asus Transformer Prime TF201 (ICS or HC supported) and the Asus Transformer TF101. It is very simple and easy to use with extra features that other root methods don't have. Works on Prime's that lost root with the ICS OTA! Now, here is how it works...
  • Download the .zip
  • Plug in your Transformer and make sure to install the drivers located in the included .zip (unless you can already adb into your device, then no need for drivers)
  • Kill Asus Sync and Splashtop! - very important!!
  • Make sure you have NO OTHER ANDROID DEVICES connected via USB!
  • If on Linux, you may need to do "chmod a+x /path/to/primetime/primetime.sh" (no quotes)
  • Run the viperMOD PrimeTime.exe and choose an option.
  • After rooting, download OTA Root Keeper from the Market!
  • ???
  • Profit?

It's as simple as that! I have tested this about 30 times (both rooting and unrooting) and it works just fine! I would HIGHLY recommend downloading Voodoo Root Keeper!! Any issues or questions, please feel free to post here! Enjoy your rooted Prime :D

Things you should NOT do!
  • Try to root with the Transformer in the dock
  • Use a USB extension cable
  • Not download OTA Root Keeper
  • Not follow directions

Updated 2.22 - v4.5
  • Added Asus Unlock Tool install and automated CWM flash

HC root based on NachoRoot by jcase and TeamAndIRC.

ICS root based on TPSparkyRoot by sparkym3.

Latest ICS root based on https://github.com/saurik/mempodroid by Saurik.


Windows (v4.5): http://bit.ly/wpcUrZ
Linux/Unix (v4.1 - update coming soon!): http://bit.ly/PrimeTime_v4_1_Linux

Edited by -viperboy-, 22 February 2012 - 11:19 AM.


OP -viperboy-


Android Beginner

  • 47 posts

Posted 04 January 2012 - 01:32 AM #2


Updated 1.25 - v4.1[list]
[*]Fixed an issue where people couldn't root, even on latest OTA. The problem was a copy of su in /system/bin (or in some cases /system/xbin) that had the wrong permissions. The fix is to remove it, repush, and set correct permissions on it

Updated 1.24 - v4

[*]Support latest OTA (.11) and up! This should (hopefully) stick around a while because of the exploit used!
[*]Code clean up
[*][B]TIP:[/B] I would recommend just updating to .11.1 from [URL="http://forum.xda-developers.com/showthread.php?t=1452933"]here[/URL] (make sure you download the large 300+MB file) and follow those directions and then try rooting. That is what I did and v4 worked on that just fine :)

Updated 1.22
[*]Added Linux/Unix version

Updated 1.12 - v3.1
[*]Added a line of code to (hopefully) fix failed rooting. This was likely caused by root failing and not undoing the code (my script has always done that on a failed root, I assume most people who are having problems now did it by hand before?)

Updated 1.12 - v3
[*]Supports ICS root method (as well as alt. root method, used on TF101 and Prime's on HC)
[*]Better busybox install
[*]Better su binary and Superuser app removal (checks /data for Superuser if you updated it in Market)
[*]More code enhancements and cleanup
[*]Added donate menu [because you guys love us :D]

Updated 1.10 - v2
[*]Name changed to PrimeTime (thanks xda user whose name I need to find!)
[*]Installs busybox upon rooting
[*]Fix bug where superuser and binary weren't removed
[*]Removes superuser.apk from /data/app if updated from Market
[*]Gives you sysro and sysrw (type that into a terminal/adb shell for quick rw/ro /system)
[*]Code enhancements and cleanup

Updated 1.4 - v1
[*]Initial Release


Q. Do I need ADB?
A. Yes, but you don't need to set it up or anything. I have packaged it as part of the .exe and it should work just fine.

Q. Will I not be able to OTA?
A. No, rooting doesn't affect OTA whatsoever. It's actually reverse - OTA affects root. You will still get update notifications when updates drops, but you WILL loose root if you update. Download Voodoo Root Keeper to keep root if you take the next OTA! The only way rooting would possibly affect an OTA is if, once rooted, you delete the certificates and modify the build.prop (and other things) that don't allow the OTAs to come through.

Q. Will this work on ICS and/or HC?
A. Yes, it now supports both. The ICS root method may work on HC Prime's and TF101's but I haven't gotten reports on that yet.

Q. The program doesn't do anything! WTF?!
A. Did you enable USB Debugging like the program told you too? [Settings > Developer Options] I hope you also installed the drivers, since the program told you to do that too. Once that is all set, the program will continue. If you're still having issues, please try this:

Originally Posted by Swiftks
Here's what I did to resolve the auto driver install by Windows 7, which does not allow for adb interface:

1) Turn USB Debugging ON (Settings -> Developer Options)
2) Allow installation of non-market apps (Settings -> Security -> Unknown Sources)
3) Uncheck Launch ASUS Sync (Settings -> Accounts & sync)

PC (Windows 7 x64):
4) Connect Prime to PC via USB & drivers automatically installed. *Note: Prime is only visible under "Portable Devices" in Device Manager.
5) Download the ViperMod .zip for Windows from the OP.
6) In Device Manager, right click on Transformer Prime TF201 (under portable devices), and choose Update Driver Software.
7) Choose Browse My Computer for Driver Software.
8) Choose Let Me Pick A List of Device Drivers on My Computer
9) If you see MTP USB Device on the next screen under ASUS Android MTP Device, choose it and click next. If you don't see this, then maybe try selecting "Have Disk" and pointing to the drivers folder in ViperMod (MTP file perhaps??).
10) Windows will install driver and and you should now also see a separate tier under Device Manager labeled, ASUS Android Devices -> ASUS Android Composite ADB Interface. If you see this you are good to go and can run the adb vipermod root process.

If you still need help with the driver install, this video tutorial might help.

Q. Why add busybox and Superuser.apk to /system? I don't want that shit!
A. Sorry I can't please you. Busybox is important because it adds many commands to the device that it doesn't have (it doesn't have basic commands like 'copy' or 'grep' [a type of find]). When you install ROMs on other devices, you have busybox. It will be necessary to things I have coming down the pipe ;) As far as Superuser getting installed to /system, you'd have to go out of your way to uninstall it. In /data, it's easy to uninstall and if you master reset, root wouldn't work because there is no app, upon reboot, that would manage apps requesting root access.



Developer Relations

Posted 04 January 2012 - 01:56 AM #3

Sweet job there sir. Will tell the masses soon.

Sent from my Galaxy Nexus using RootzWiki

Remember - Remain respectful to others as you would wish to be treated.
Please read the RULES before posting.

Want to sign up to be a developer? Check the requirements.



Average Android

  • 120 posts

Posted 04 January 2012 - 03:42 AM #4

Good job on this! Quick question: if I already rooted my prime using the adb method jcase posted earlier, would I be able to Unroot using this tool?

Sent from my ROOTED Transformer Prime



Android Beginner

  • 93 posts

Posted 04 January 2012 - 10:29 AM #5

Awesome, thanks. Will root and report back tonight.



Average Android

Posted 04 January 2012 - 02:24 PM #6

Dumb question... But how do I install the drivers?



Average Android

  • 2 posts

Posted 04 January 2012 - 03:49 PM #7

so, ?, with this root method i wont have officially unlock my bootloader from asus and void my warranty. does this by pass that step? thanks in advance.



Android Beginner

  • 5 posts

Posted 05 January 2012 - 05:49 PM #8

What nation? Dough nation!



Droid Goader

Posted 12 January 2012 - 07:27 AM #9

Just rooted using the new vipermod v3 root method. Worked after ICS OTA update. Word of warning if you have the dock. I had mine docked and it never reconnected with my computer to continue the process. I just about shat myself as my TP just kept rebooting. I undocked and reconnected and it completed the root just fine.
Nobody believes the official spokesman, but everybody trusts an unidentified source.



Android Lover

  • 103 posts

Posted 19 January 2012 - 09:38 AM #10

I rooted with vipermod last night (ICS) and it worked. However, I then tried installing the OTA GPS fix and it won't install.