Jump to content

  1. 0
  2. 0
  3. 0/5

Rate this Topic

* * * * *
114 votes

[Kernel][jb43] [v8.3, FINAL] Leankernel: Minimalistic Kernel

  • Please log in to reply

Mr. Steve

Mr. Steve

That one guy...

  • 434 posts

Posted 07 March 2012 - 06:06 AM #6151

just for kicks can you check your display time out? When you unplug hour phone the screen will be on and I think it stays on the time out amount unless its manually turned off. Not a fan of that ics "feature".
My display time out is set at ten minutes, but when I unplugged the phone from the charger, the screen turned on, but I turned it off and put it screen up on my table.

Are you sure the screen was not on that long? Did you actually see the screen shut off after 3 seconds?

Sent from my Galaxy Nexus using Tapatalk


  • 0 Likes

Current:
Google Nexus 4 running MMuzzy's French Vanilla AOSP (Jan 12); Franco's r53 kernel; TWRP 2.3.3.2

Google Nexus 7 running MMuzzy's French Vanilla AOSP (Jan 13); Franco's r41 kernel;

Retired: Galaxy Nexus (CDMA), Motorola Droid 2, Motorola Droid


Mr. Steve

Mr. Steve

That one guy...

  • 434 posts

Posted 07 March 2012 - 06:11 AM #6152

Here's another screenshot of my wake locks. I would rather not post screenshots from BetteryBatteryStats because my email address is in the screenshots, just take my word for it, the biggest wake lock I have is 1:38 minutes in kernel wake lock and 1:12 minutes in partial wake lock.

Attached Thumbnails

  • Screenshot_2012-03-07-09-01-59.png

  • 0 Likes

Current:
Google Nexus 4 running MMuzzy's French Vanilla AOSP (Jan 12); Franco's r53 kernel; TWRP 2.3.3.2

Google Nexus 7 running MMuzzy's French Vanilla AOSP (Jan 13); Franco's r41 kernel;

Retired: Galaxy Nexus (CDMA), Motorola Droid 2, Motorola Droid


MonkeyMan

MonkeyMan

Average Android

  • 5 posts

Posted 07 March 2012 - 07:33 AM #6153

Battery life for me has been great. Kernel is smooth. My only issue is sometimes i have to double hit the power button for the device to turn on. Like the first press doesn't register always. Not sure why this happens.
  • 0 Likes

itsmikeramsay

itsmikeramsay

Android Abuser (LOL)

Posted 07 March 2012 - 07:40 AM #6154

Hi All - new here, but have been experimenting with the various kernels for a little while. I started following FK, but after his more recent releases, I started to experience problems with lock ups and static sounds. I gave up and just after I restored back to stock 4.0.4, I recalled people mentioning 'minimalistic..' and thought: That's what I need! Just a straight forward approach to improving GN performance. If anything, it would make it easier to troubleshoot, especially with the talent on this thread. I also like how organized IMO keeps things around here :)

So far, I've been getting great stability and performance using the latest 2.4 exp1 untrimed. I use 230-1520 and as long as I don't fuss with the UV, things are looking solid. As I mentioned before, I started to have problems with FK and among those issues was the ability to reconnect to LTE (or any mobile data network services). I can't replicate it, but I can consistently restore it by either 1) rebooting or 2) toggle between 3G then select 4G. Maybe it was Juice Defender, but I uninstalled that awhile ago, and I seem to be losing the mobile data again now.. even on the stable versions of the lean kernels. Here's the sequence of events that closely resembles what I'm doing:

1. wifi on / mobile data off
2. turn wifi off / mobile data on to confirm. (4G ok)
3. return to step 1
4. after time goes by - turn screen on and try enabling mobile data. Neither 4G or 3G has connection and I must 'toggle' in the mobile network setup to enable it again.

I hope this makes sense. I'm thinking of trying juice defender again, but what to learn what's happening with the mobile data radios first. Could this be related to a kernel thing?

Thanks for your assistance!


What radios do you have installed bro? When I used 4.0.4 radios, I had similar issues.

Sent from my Galaxy Nexus using Tapatalk
  • 0 Likes

Posted Image

~*Feedback, Thanks and 5-Star Ratings are all appreciated!*~

Twitter: @ItsMikeRamsay

Current Device: T-Mobile HTC One S, Nexus 7 (Soon!)

Previous Device: Droid 1, HTC Sensation 4G, Galaxy Nexus LTE


OP imoseyon

imoseyon

Developer

Posted 07 March 2012 - 08:08 AM #6155

leanKernel 2.4.1
  • fixes a gpu reboot bug that was affecting at least one person
  • removed gpu debug stuff for leaner kernel
  • a cpu0/cpu1 lock up fix from android-omap source
Experimental versions will come tonight. Not a huge difference from 2.4.0 though.

Edited by imoseyon, 07 March 2012 - 08:08 AM.

  • 2 Likes

ryanrodio

ryanrodio

Average Android

Posted 07 March 2012 - 08:32 AM #6156

leanKernel 2.4.1

  • fixes a gpu reboot bug that was affecting at least one person
  • removed gpu debug stuff for leaner kernel
  • a cpu0/cpu1 lock up fix from android-omap source
Experimental versions will come tonight. Not a huge difference from 2.4.0 though.


It's been 41 hours since I unplugged my phone. Using 2.4.0 has me still at 25% left.
Your kernel is the bzzzzaomb!
  • 0 Likes

mikeymop

mikeymop

Warning: Low Battery

Posted 07 March 2012 - 08:35 AM #6157

I don't think so I'm almost positive that when you take it off the charger the battery graph and stats all reset. Mine will tell me 10 sec. on battery and won't show anything from when it was charging just data from after I pulled the charger.

Now for the awake time that's pretty strange esp. if you haven't installed some new apps that run background processes. The biggest thing is if you can reproduce it. There have been some reports of random crazy battery drain and maybe your phone was in the middle of one. Abqn was the first to mention them where the battery will just drain completely in 3 hours and the phones not being used. I got my first one last week, not quite as bad as abqn but my battery drained 50% in 8 hours while i was sleeping usually I have a 2-4% drain in that time period with my phone in the exact same spot. So I would just reboot if you haven't already and see if the problem recurs. If not just chalk it up to a random event.

It only resets if you reach a full charge, I've gone to 92 and back a few times and my graph spanned a few days.
  • 0 Likes
PM me if you need any help!

ExiledThemer

ExiledThemer

Android Master

  • 896 posts

Posted 07 March 2012 - 08:38 AM #6158

sweet...trying the new stable now. Just installed after wiping dalvik and cache. Hope that was what the cause of my issues were at least.
  • 0 Likes

mistywindy

mistywindy

Member

  • 50 posts

Posted 07 March 2012 - 09:01 AM #6159

Here's another screenshot of my wake locks. I would rather not post screenshots from BetteryBatteryStats because my email address is in the screenshots, just take my word for it, the biggest wake lock I have is 1:38 minutes in kernel wake lock and 1:12 minutes in partial wake lock.


I unfortunately cannot offer a solution, but I offer confirmation that I have the same issue. My wake-locks are not as bad as yours, but I did an overnight drain test last night.

Drain over 9hr 15 min idle was 20%, standard battery (so about 2.16% per hour)
Betterbattery stats reports a total of 4-5 kernel wakelocks and and total of 5-6 partial wakelocks, none spanning over 1-2min
Stock battery graph reports one giant looking wake-lock that seems to span (visually estimating) 1-2 hours

I can try to go grab screenshots upon request, I was just feeling lazy about it and hoped you all would take me at my word. Here's my setup: 2.4.0exp2(230) but mix 350 max 1350, hotplugx, UV set to NEW leantweaks presets with zram/swap/system speedup/sdcard speedup all enabled. Wifi on, Data on, Sync on.

The craziest thing is my screen-on time during normal use testing yesterday was excellent. 2h19m screen on after 7 hours on total with 50% battery. It's only idle drain that seems to be the problem.

Might try overnight testing again with all leantweaks disabled, and then adding them on one by one and repeating, to see if any of them could be the culprit.

Edited by mistywindy, 07 March 2012 - 09:04 AM.

  • 0 Likes

cuzzinz

cuzzinz

Android Lover

  • 134 posts

Posted 07 March 2012 - 09:13 AM #6160

I think I am starting to get frustrated by the people posting screenshots using wifi lol.

So... I guess it is time to ask everyone again... With normal use what kind of battery life are you guys seeing? NO WIFI! :-P (These 1-2 day battery life posts seem to all be on WIFI...if not please let us know your trick)

Personally, if I don't obsess over my battery drain I can see between 10-12 hours of battery life with moderate usage. This with moderate 4g/3g coverage. How am I doing compared to the rest of you guys?

BTW do you guys have force 2d gpu rendering enabled?
  • 0 Likes