Jump to content

  1. 0
  2. 0
  3. 0/5

Rate this Topic

* * * * *
114 votes

[Kernel][jb43] [v8.3, FINAL] Leankernel: Minimalistic Kernel

  • Please log in to reply

Arvylas

Arvylas

Super User

  • 323 posts

Posted 06 May 2012 - 10:17 AM #10021

First time using hotplugx and realized that not only has much better battery than IX but it is more responsive too. Another thing is that CPU scales up less even though I have set up threshold at 90 and with IX I had it at 95. It seems that ondemand (hotplug) at the moment is at a better shape than interactive. IMO what's your opinion about this?

Sent from my Galaxy Nexus using Tapatalk 2
  • 0 Likes

joshuauy

joshuauy

Android Beginner

  • 102 posts

Posted 06 May 2012 - 10:56 AM #10022

So I'm on winner's cm9 build (the one from 05/04), and when I was on 3.4.0 exp4, gamma control worked in the advanced menu in settings. I'm now on the 3.5.0 stable, and that menu is greyed out. I can still get into the color multipliers menu.

When I was on 3.4.0 stable, I also could not get into the gamma menu.

I toggled the "CC" script through both options, but it stays greyed out for both.

The gamma menu did work for me on stable at one point (3.3.0 maybe?) because I remember having to drag the sliders up to 60 60 60. That was around the time cm9 went back to 0 0 0 as default. So when I booted up with default gamma settings, everything was green until I pulled them to 60 60 60.

Is there a reason why gamma control would be greyed out for me on 3.5.0 stable but working on the exp line?

Like is there some sysfs value I need to change to get the stable working again?

Also, another question, templimit with 0 (like on the stable) means it's disabled and defaults to the stock 63 degC limit, right?

Thanks in advance.

Sent from my Galaxy Nexus using RootzWiki
  • 0 Likes

Metallice

Metallice

Android Lover

  • 153 posts

Posted 06 May 2012 - 11:38 AM #10023

So... Did anyone else not have bootloops with SR enabled at 1.5/1.65 on 3.50exp1 or do imoseyon and I just have the two best Gnexuses in the world? :/

Edited by Metallice, 06 May 2012 - 11:39 AM.

  • 0 Likes

bigeyes0x0

bigeyes0x0

Super User

Posted 06 May 2012 - 11:47 AM #10024

Weird behavior:
Kernel: 3.5.0 stable
ROM: IMM76I GSM
Reproduce procedure: Set UV with echo 1325 1180 1080 1010 900 > /sys/devices/system/cpu/cpu0/cpufreq/UV_mV_table , then use checkv to apply the undervolt without letting the phone turning off its screen and I got this:
leanKernel Voltage Checker
--------------------------
Nominal Voltage - This is the voltage we choose as the starting point.
Calibrated Voltage - Best voltage chosen by SmartReflex.

Make sure that your screen is turned on...

350000: nominal 900000, calibrated 840000
700000: nominal 900000, calibrated 840000
920000: nominal 900000, calibrated 840000
1200000: nominal 900000, calibrated 840000
After that the phone feels really sluggish even if I set the UV values back to default, I had to give up using it if I want to use the stable version. UV works fine on 3.5.0exp2 BTW.

Edited by bigeyes0x0, 06 May 2012 - 11:47 AM.

  • 0 Likes
My app Trickster MOD, kernel settings and performance tweaks.

Support and Feedback | Google+ Page | Help us translate

headcheese

headcheese

Android Apprentice

  • 347 posts

Posted 06 May 2012 - 12:18 PM #10025

So... Did anyone else not have bootloops with SR enabled at 1.5/1.65 on 3.50exp1 or do imoseyon and I just have the two best Gnexuses in the world? :/


Mine works fine.

Sent from my Galaxy Nexus using Tapatalk 2
  • 0 Likes

ashclepdia

ashclepdia

Android Beginner

  • 776 posts

Posted 06 May 2012 - 12:45 PM #10026

Finally, can you explain the physical hardware blocks that MPU and Core represent? I've come to understand that the MPU are the physical CPU cores, but I must admit I'm a little confused on what "core" represents, if not the CPUs.

Have you tried on the newer version enabling the wifi screen off boost mod?
And i believe the core refers to GPU
At least thats what I've gathered from the info available in other kernels' apps
Sent from my Galaxy Nexus using Tapatalk 2
  • 0 Likes

Metallice

Metallice

Android Lover

  • 153 posts

Posted 06 May 2012 - 12:48 PM #10027

Can anyone with hardware revision 10 NOT use 3.50exp1with SR at 1.5/1.65? Likewise can anyone with revision 9 use exp1 stably with SR at 1.5/1.65??
  • 0 Likes

DarthG

DarthG

Yarr! It's a pirate's life for me

Posted 06 May 2012 - 01:02 PM #10028

Can anyone with hardware revision 10 NOT use 3.50exp1with SR at 1.5/1.65? Likewise can anyone with revision 9 use exp1 stably with SR at 1.5/1.65??

HW Revision 10 Maguro, 3.5.0exp1 w/ sr1.5 works fine, but I'm still flashing to exp2 just cuz it's the newest.
  • 0 Likes
Come and join Dropbox here so that we can both enjoy more free storage!

Metallice

Metallice

Android Lover

  • 153 posts

Posted 06 May 2012 - 01:49 PM #10029

HW Revision 10 Maguro, 3.5.0exp1 w/ sr1.5 works fine, but I'm still flashing to exp2 just cuz it's the newest.


I'm just curious because so far with the people who tried my kernel build on xda and have actually gotten back to me this has been the case.

3 hw r10s - all can run SR1.5 at 1500/1650
2 hw r9s - all reboot or freeze if they change max to 1500 or 1650.

Just an interesting trend.
  • 0 Likes

ashclepdia

ashclepdia

Android Beginner

  • 776 posts

Posted 06 May 2012 - 01:50 PM #10030

Imo!
I think i might have something to help you figure out what happened with 3.5exp1
I'm on that right now
I used lean tweaks
I tried to do smart reflex calibration.
Here is what shows
I'm pretty sure that's what is causing reboots
I only get a reboot when trying to bench Mark with 1.52+ enabled
And since phone doesn't go to 1.5+ often that could explain why not everyone is seeing the issue
A calibrated 0 voltage would definitely cause an issue right? :)
Posted Image

Sent from my Galaxy Nexus using Tapatalk 2
  • 0 Likes