Jump to content

  1. 0
  2. 0
  3. 0/5

Rate this Topic

- - - - -

Wifi Tether

  • Please log in to reply

OP jtclarke88

jtclarke88

Android Beginner

  • 21 posts

Posted 20 November 2011 - 10:02 PM #1

So what I've noticed is there are two methods to achieve wifi tether on the Razr and have it work properly. I'll list the steps for both for whoever might be interested. (Root is required for both)

First method will hack the verizon tether. (I've had issues with this but it may work for you)
1. Download SQLite Editor from market. (Be advised it is a paid app)
2. Open SQLlite Editor.
3. Access Settings Srotage (com.motorola.android.providers.settings) Will have wrench and hammer icon
4. Open Settings.db
5. open settings
6. scroll to item 150 (entitlement_check) and long press the 1
7. tap edit field change value from 1 to 0
8. save settings and restart phone
9. you should now be able to use the tethering feature verizon loaded on phone
*Note* Some people have had problems with it not loading pages properly using this method. If this is the case use method 2

Method 2

1. Go to this link using your phone and download the .apk file

http://android-wifi-...v3_1-pre104.apk (thanks to tekahuna for the updated file tested and working fine)

2. Install .apk (make sure you allow unknown sources in settings/applications)
3. Open wifi tether and go to settings
- Change device profile - motorola targa
- Check Enable Wifi Encryption
- Change password if desired
- Change channel to channel 06 (you can try other channels but this seems to yield the best results)
4. Close and reopen wifi tether (may need to end process in task manager)

That should work around any problems you are experiencing using the wifi tether. I do not take credit for these methods I just thought it would be beneficial to consolidate the work arounds for anyone experiencing the same problems that I was.

Edited by jtclarke88, 23 November 2011 - 06:38 AM.

  • 1 Likes

gulmiguel

gulmiguel

Supporting Member

Posted 21 November 2011 - 05:44 PM #2

Thanks for Method 2 - so far it seems to be working fabulously. One question....access control was disable, i decided to enable it and apply it to the MAC address that shows up in the tether program the device i was connecting. What is access control and should I enable or disable it? TIA.
  • 0 Likes
[SIGPIC][/SIGPIC]

Miguel T. Velez-White
Gallano-Velez Consultech, LLC
9077 US Highway 29 N
Cusseta, AL 36852
miguel.velez-white@gvconsultech.net

OP jtclarke88

jtclarke88

Android Beginner

  • 21 posts

Posted 21 November 2011 - 06:18 PM #3

From what I understand. (And I'm no expert) Access control will allow you to choose which devices can connect to your hotspot by limiting the devices MAC address. On this version of wifi tether access control is known to be buggy (or so I've heard). So my reccomendation would be to leave it disabled for now.
  • 1 Likes

tekahuna

tekahuna

teh-kuh-hoo-nuh Overclocking & Tether Guy

Posted 22 November 2011 - 10:13 AM #4

Method 2

1. Go to this link using your phone and download the .apk file

http://code.google.c...apk&can=2&q=<br /><br />S

2. Install .apk (make sure you allow unknown sources in settings/applications)
3. Open wifi tether and go to settings
- Change device profile - motorola targa
- Check Enable Wifi Encryption
- Change password if desired
- Change channel to channel 06 (you can try other channels but this seems to yield the best results)
4. Close and reopen wifi tether (may need to end process in task manager)

That should work around any problems you are experiencing using the wifi tether. I do not take credit for these methods I just thought it would be beneficial to consolidate the work arounds for anyone experiencing the same problems that I was.


There is a new build, v3.1-pre104
http://android-wifi-...v3_1-pre104.apk

What's New:
1. Fixed error that causes hostapd to fail when encryption isn't enabled. (You can create open networks now)
2. Fixed auto device detection for Droid Bionic, and added profiles for Droid 3 and Droid RAZR. You shouldn't need to choose a profile anymore.

Please test, and update OP to reflect.... Thankyou!

Note on Access Control: Access control blocks IP traffic based on MAC address. Useful for when you must have an open network(because you have a certain device that doesn't do encryption well, or at all), but would like to limit who can use your AP. AC appeared to work properly when I tested it out... But, if you've got encryption enabled, AC is kind of pointless...
  • 1 Likes

gulmiguel

gulmiguel

Supporting Member

Posted 22 November 2011 - 04:15 PM #5

Thanks to both tekahuna and jtclark88. You guys have answered all my noob type questions to my satisfaction. I truly appreciate it. I'm giving some thought to trying the new version that just got posted. I'll keep you all updated on how it goes - from the descriptions of what's new, I'm very excited to try.
  • 0 Likes
[SIGPIC][/SIGPIC]

Miguel T. Velez-White
Gallano-Velez Consultech, LLC
9077 US Highway 29 N
Cusseta, AL 36852
miguel.velez-white@gvconsultech.net

Neutronbomb

Neutronbomb

Android Beginner

  • 4 posts

Posted 23 November 2011 - 06:02 PM #6

Is there anyway to make this work as an ad-hoc connection? Something about my office blocks infrastructure mode wifi networks. Only way I can tether to my 10.1 is through ad-hoc.
  • 0 Likes

Snow02

Snow02

Android Lover

  • 1,260 posts

Posted 23 November 2011 - 06:21 PM #7

Is there anyway to make this work as an ad-hoc connection? Something about my office blocks infrastructure mode wifi networks. Only way I can tether to my 10.1 is through ad-hoc.


What do you mean by "blocks infrastructure mode wifi networks"? It sounds like you're suggesting there's an interference issue. There's not anything that will selectively kill an infrastructure signal vs. an ad-hoc one. They both travel over the same protocol and frequencies. Perhaps try a different channel.
  • 0 Likes

Neutronbomb

Neutronbomb

Android Beginner

  • 4 posts

Posted 23 November 2011 - 08:57 PM #8

What do you mean by "blocks infrastructure mode wifi networks"? It sounds like you're suggesting there's an interference issue. There's not anything that will selectively kill an infrastructure signal vs. an ad-hoc one. They both travel over the same protocol and frequencies. Perhaps try a different channel.




I work inside an aircraft hangar on an Air Force base. For some reason if you try to use a wifi hotspot or use your phone to tether it will not work. I don't think there is something intentionally blocking it, I believe it's just interference of some sort. I've tried on a Droid X, G2X, Thunderbolt, Charge and a Bionic. I've also tried on every possible frequency/channel settings. You can connect but it's constantly disconnecting and reconnecting. The only way to get a stable connection is to set the tether app to ad-hoc mode... it's the only option and it works great.

I couldn't begin to guess why that works but it does across multiple devices. The wifi tether app used to have the option to set it to ad-hoc mode but this newer version doesn't.




Also wanted to add this theory has been tested with a Galaxy tab 10.1, wifi and 3g Xooms, a transformer an ipad2 and a laptop. None of them would stay connected for more than a few seconds at a time on an infrastructure mode connection. People who bought those wifi hotspot things are pissed because they won't work in the building so it's not just me or my phone.

Edited by Neutronbomb, 23 November 2011 - 08:59 PM.

  • 0 Likes

Snow02

Snow02

Android Lover

  • 1,260 posts

Posted 23 November 2011 - 09:04 PM #9

Definitely odd, I'll give you that.
  • 0 Likes

TimDotThomas

TimDotThomas

Android Beginner

  • 13 posts

Posted 26 November 2011 - 08:08 PM #10

This is great. Now can Verizon find out that I am tethering?
  • 0 Likes